point-to-point のframe-relay接続とOSPF認証




条件
・R1とR2にてframe-relay設定をしてください。
・R1とR間にてOSPFをコンバージェンスし、OSPF認証をタイプ1にて設定してください。


まず下記設定からスタートです。

R1
interface Serial1/0
no ip add
encap frame-relay
!
interface s1/0.102
ip add 1.1.1.1 255.255.255.0
ip ospf net point-to-point
frame-relay interface-dlci 102
!
interface s1/0 103
ip add 2.2.2.1 255.255.255.0
ip ospf net point-to-point
frame-relay interface-dlci 103
!
interface lo0
ip add 10.10.10.10 255.255.255.255
!
router ospf 1
 redistribute connected subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 2.2.2.1 0.0.0.0 area 0

R2
interface Serial1/0
ip address 1.1.1.2 255.255.255.0
encap frame-relay
ip ospf net point-to-point
frame-relay map ip 1.1.1.1 201 broadcast
!
inteface s1/1
ip add 2.2.2.2 255.255.255.0
encap frame-relay
ip ospf net point-to-point
frame-relay map ip 2.2.2.1 301 broadcast
!
interface lo0
ip address 20.20.20.20 255.255.255.0
!
router ospf 1
 redistribute connected subnets
 network 1.1.1.2 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0


ポイントとしては、R1側のサブインターフェースで、frame-relay interface-dlci
を設定していることですかね。サブインターフェースで、frame-relay map を
設定しようとするとはじまれますね。↓こんなかんじで。。

R1(config-subif)#frame-relay map ip 1.1.1.2 102
Only frame-relay interface-dlci command should beused on point-to-point interfa
ces not frame-relay map
R1(config-subif)#

R1 で sh ip route を見るとロードバランスされていることがわかりますね。

R1#sh ip route
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial1/0.102
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Serial1/0.103
     20.0.0.0/32 is subnetted, 1 subnets
O E2    20.20.20.20 [110/20] via 2.2.2.2, 00:08:13, Serial1/0.103
                    [110/20] via 1.1.1.2, 00:08:13, Serial1/0.102
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0


これで、1こめの条件は達成なので、2こめの条件、認証を設定してみますか。
ちなみにタイプ0は認証なし。タイプ1は平文認証、タイプ2は暗号化認証です。

R1
interface s1/0.102
ip ospf authentication
ip ospf authentication-key cisco
!
interface s1/0.103
ip ospf authentication
ip ospf authentication-key cisco

R2
interface s1/0
ip ospf authentication
ip ospf authentication-key cisco
!
interface s1/1
ip ospf authentication
ip ospf authentication-key cisco

ってかんじですね。
タイプ2(md5暗号化)でやりたい場合は、

R1
interface s1/0.102
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
!
interface s1/0.103
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

R2
interface s1/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
!
interface s1/1
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

って感じです。

エリア認証の場合は、ってこれは省略。
こちらをみてください。

更新日:2012年8月12日