RIP 認証設定




条件
・R1とR2にてRIP をコンバージェンスさせてください。
・RIPはMD5ハッシュにて認証設定をしてください。


まず下記設定からスタートです。

R1
interface Serial1/0
ip add 192.168.0.1 255.255.255.0
!
interface lo0
ip add 10.10.10.10 255.255.255.255
!
router rip
 version 2
 network 192.168.0.0
 network 10.0.0.0

R2
interface Serial1/0
ip add 192.168.0.2 255.255.255.0
!
interface lo0
ip add 20.20.20.20 255.255.255.255
!
router rip
 version 2
 network 192.168.0.0
 network 10.0.0.0



上記普通にコンバージェンスさせた状態で、片方だけ認証を設定してみます。

R1
key chain RIP
key 1
key-string cisco

interface s1/0
ip rip authentication mode md5
ip rip authentication key-chain RIP

これでR2にて debug ip rip events を取得してみます。

*Aug 15 21:58:26.555: RIP: Update contains 2 routes
*Aug 15 21:58:26.559: RIP: Update queued
*Aug 15 21:58:26.563: RIP: Update sent via Loopback0
*Aug 15 21:58:26.595: RIP: ignored v2 packet from 20.20.20.20 (sourced from oneof our addresses)
*Aug 15 21:58:47.203: RIP: ignored v2 packet from 192.168.0.1 (invalid authentication)
*Aug 15 21:58:52.091: RIP: sending v2 update to 224.0.0.9 via Serial1/0 (192.168.0.2)
*Aug 15 21:58:52.091: RIP: Update contains 1 routes
*Aug 15 21:58:52.091: RIP: Update queued
*Aug 15 21:58:52.091: RIP: Update sent via Serial1/0
*Aug 15 21:58:53.663: RIP: sending v2 update to 224.0.0.9 via Loopback0 (20.20.20.20)
*Aug 15 21:58:53.667: RIP: Update contains 2 routes
*Aug 15 21:58:53.671: RIP: Update queued
*Aug 15 21:58:53.671: RIP: Update sent via Loopback0
*Aug 15 21:58:53.679: RIP: ignored v2 packet from 20.20.20.20 (sourced from oneof our addresses)


認証がinvalid でダメです。とでてきます。
R2側も同じように設定を入れます。

R2
key chain RIP
key 1
key-string cisco

interface s1/0
ip rip authentication mode md5
ip rip authentication key-chain RIP


Gateway of last resort is not set

R    20.0.0.0/8 [120/1] via 192.168.0.2, 00:00:02, Serial1/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0
C    192.168.0.0/24 is directly connected, Serial1/0

これで、ルートを受け取り、渡すことができました。
上記設定はMD5 の設定となり、クリアテキスト認証は下記を追加するかんじです。

R1
key chain RIP
key 1
key-string cisco

interface s1/0
ip rip authentication mode text
ip rip authentication key-chain RIP


R2
key chain RIP
key 1
key-string cisco

interface s1/0
ip rip authentication mode text
ip rip authentication key-chain RIP

少ないけど以上ですー

更新日:2012年8月15日