virtual-link を使わずにarea 1をまたいだarea0,2 の通信(tunnel interface)





条件Lab2.1 とあわせて
・エリア1を nssa エリアにしなさい。
・エリア0とエリア2を通信できるようにしなさい。

エリア1がnssaなので、virtual-link は使えません。 ということで方法として area 0 のtunnel interface を作ることで無理やりarea 0 を拡張します。

下記の状態からスタート。

R1
interface Serial1/0
 ip address 1.1.1.1 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
net 1.1.1.1 0.0.0.0 area 0

R2
interface Serial1/0
 ip address 1.1.1.2 255.255.255.0
interface Serial1/1
 ip address 2.2.2.2 255.255.255.0
!
router ospf 1
router-id 2.2.2.2
network 1.1.1.2 0.0.0.0 area 0
network 2.2.2.2 0.0.0.0 area 1
area 1 nssa no-summary

R3
interface Serial1/1
 ip address 2.2.2.3 255.255.255.0
interface Lo0
 ip add 30.0.0.3 255.255.255.255
!
router ospf 1
router-id 3.3.3.3
network 2.2.2.3 0.0.0.0 area 1
network 30.0.0.3 0.0.0.0 area 2
area 1 nssa




概要は LAB2.1で説明したとおりなので、tunnel interface を設定しちゃってみましょう。


R2
interface tunn 0
ip add 20.20.20.2 255.255.255.0
tunn source s1/1
tunn destination 2.2.2.3
!
router ospf 1
net 20.20.20.2 0.0.0.0 area 0

R3
interface tunn 0
ip add 20.20.20.3 0.0.0.0 area 0
tunn source s1/1
tunn destination 2.2.2.2

router ospf 1
net 20.20.20.3 0.0.0.0 area 0

ここまで設定してR1でsh ip route を見ると、O IA で R3 のLo0
が見えていることが確認できます。

R1
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O IA    2.2.2.0 [110/128] via 1.1.1.2, 00:00:18, Serial1/0
     20.0.0.0/24 is subnetted, 1 subnets
O       20.20.20.0 [110/11175] via 1.1.1.2, 00:00:18, Serial1/0
     30.0.0.0/32 is subnetted, 1 subnets
O IA    30.0.0.3 [110/11176] via 1.1.1.2, 00:00:18, Serial1/0

更新日:2012年8月4日